127 lines
3.4 KiB
Nix
127 lines
3.4 KiB
Nix
{
|
|
inputs = {
|
|
nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
|
|
|
|
flake-utils.url = "github:numtide/flake-utils";
|
|
|
|
home-manager = {
|
|
url = "github:nix-community/home-manager";
|
|
inputs.nixpkgs.follows = "nixpkgs";
|
|
inputs.utils.follows = "flake-utils";
|
|
};
|
|
|
|
base16-rofi = {
|
|
url = "github:tinted-theming/base16-rofi";
|
|
flake = false;
|
|
};
|
|
base16-kitty = {
|
|
url = "github:kdrag0n/base16-kitty";
|
|
flake = false;
|
|
};
|
|
base16-kermit = {
|
|
url = "github:orhun/base16-kermit";
|
|
flake = false;
|
|
};
|
|
tinted-foot = {
|
|
url = "github:tinted-theming/tinted-foot";
|
|
flake = false;
|
|
};
|
|
tinted-vscode = {
|
|
url = "github:tinted-theming/tinted-vscode";
|
|
flake = false;
|
|
};
|
|
base16-vim = {
|
|
url = "github:chriskempson/base16-vim";
|
|
flake = false;
|
|
};
|
|
rycee = {
|
|
url = "gitlab:rycee/nur-expressions";
|
|
flake = false;
|
|
};
|
|
firenvim = {
|
|
url = "github:glacambre/firenvim";
|
|
flake = false;
|
|
};
|
|
schemer2 = {
|
|
url = "github:thefryscorer/schemer2";
|
|
flake = false;
|
|
};
|
|
auto-base16-theme = {
|
|
url = "git+https://macoy.me/code/macoy/auto-base16-theme.git";
|
|
flake = false;
|
|
};
|
|
npmlock2nix = {
|
|
url = "github:nix-community/npmlock2nix";
|
|
flake = false;
|
|
};
|
|
plasma-manager = {
|
|
url = "github:pjones/plasma-manager";
|
|
inputs.nixpkgs.follows = "nixpkgs";
|
|
inputs.home-manager.follows = "home-manager";
|
|
};
|
|
bemoji = {
|
|
url = "github:marty-oehme/bemoji";
|
|
flake = false;
|
|
};
|
|
bwmenu = {
|
|
url = "github:mattydebie/bitwarden-rofi";
|
|
flake = false;
|
|
};
|
|
};
|
|
|
|
outputs = {
|
|
self,
|
|
nixpkgs,
|
|
...
|
|
} @ inputs: {
|
|
nixosModules = let
|
|
m = {
|
|
ezpassthru = import ./modules/ezpassthru.nix;
|
|
ezwg = import ./modules/ezwg.nix;
|
|
fuckingprint = import ./modules/fuckingprint.nix;
|
|
workstation = import ./modules/workstation.nix;
|
|
ezpw = import ./modules/ezpw.nix;
|
|
de2 = import ./modules/de2.nix;
|
|
de3 = import ./modules/de3.nix;
|
|
ezpc = import ./modules/ezpc.nix;
|
|
nix-ssh-agent = import ./modules/nix-ssh-agent.nix;
|
|
};
|
|
in
|
|
m
|
|
// rec {
|
|
all = {...}: {
|
|
imports = builtins.attrValues m;
|
|
};
|
|
|
|
common = import ./common.nix all;
|
|
common-notgne2 = import ./users/notgne2.nix;
|
|
common-glooder = import ./users/glooder.nix;
|
|
common-chekkie = import ./users/chekkie.nix;
|
|
};
|
|
|
|
homeManagerModules = let
|
|
m = {
|
|
ezpcusr = import ./home-manager/modules/ezpcusr.nix inputs;
|
|
colors = import ./home-manager/modules/colors.nix inputs;
|
|
fonts = import ./home-manager/modules/fonts.nix;
|
|
gaming = import ./home-manager/modules/gaming.nix inputs;
|
|
kermit = import ./home-manager/modules/kermit.nix;
|
|
de2u = import ./home-manager/modules/de2u.nix inputs;
|
|
de3u = import ./home-manager/modules/de3u.nix inputs;
|
|
elvish = import ./home-manager/modules/elvish.nix;
|
|
};
|
|
in
|
|
m
|
|
// rec {
|
|
all = {...}: {
|
|
imports = builtins.attrValues m;
|
|
};
|
|
|
|
common = import ./home-manager/common.nix inputs all;
|
|
common-notgne2 = import ./home-manager/users/notgne2.nix inputs;
|
|
common-glooder = import ./home-manager/users/glooder.nix;
|
|
common-chekkie = import ./home-manager/users/chekkie.nix;
|
|
};
|
|
};
|
|
}
|